Missing Dependencies Python Core / win32api

Hi Team,
When I am trying to install virtualbox, i get the error message as shown in the image below

image

It says Missing Dependencies Python Core / win32api

I proceeded with the installation but when I try to run the CentOS VM i get different error messages.

How do I resolve the first ‘missing dependencies’ error message shown in the image above.

Please advise and i am stuck and unable to proceed further with the course.

Best Regards
Sanjith

Hi, @Sanjith-R-Warrier

Which OS do you use to install Virtual Box?
I have some references here that may help you solve the problem:
https://forums.virtualbox.org/viewtopic.php?f=7&t=95577
https://forums.virtualbox.org/viewtopic.php?f=1&t=107338
Also, in this installation guide How to Install VirtualBox 7.0 - SYSNETTECH Solutions, the missing dependencies are flagged as warnings, and we can keep moving in the installation process.
Can you attach the error message when you run CenOS so we can have a look?

Happy learning,
Trung.

To resolve this error, first install python from here Download Python | Python.org

Once python is installed, open cmd and execute the below command

pip install pywin32

After this you can start the virtualbox installation and proceed without such warnings.

5 Likes

Hello @naveenreddyjboss,

Thanks for sharing your solutions with the community.

Happy learning,
Trung.

@naveenreddyjboss
Screenshot 2022-11-23 143620
is there an alternative

Try directly from CMD not from the py console.
Elevation of privileges may be required.

@a_charuba I downloaded py and once I entered the command (pip install pywin32) into cmd I kept coming up with the error “‘pip’ is not recognized as an internal or external command,
operable program or batch file.”

I attempted some online troubleshooting (i.e.: How to Fix ‘Pip‘ is Not Recognized as an Internal or External Command ) but it’s still coming up with the same error and keep coming up with “Missing Dependencies Python core / win32api”

I’m afraid you still don’t have the path correctly added. Try running directly from C:\Users\Username\AppData\Local\Programs\Python\Python**\Scri
Fri
** python version

Hello, I customized my path, so I guess that’s why I can’t find the thing you’re mentioning?
It’s on my D: disk, what should i be looking for here?

I Uninstalled and installed it again by checking the set PATH box this time. It works now, sry for bothering :d. (I’m a beginner at this stuff :smile:

No such directory exists on my computer.


i downloaded the win32 thing and it still tells me there is a problem

Hello, Thank you for this advice. I uninstalled VirtualBox and then proceeded into command line and typed:

pip install pywin32

However, I got the following messages:

Installing collected packages: pywin32
Successfully installed pywin32-305
Warning: There was an error checking the latest version of pip

Do you have any advice sir?

Thank you,
Lisa

Okay, actually resolved this issue:

Warning: There was an error checking the latest version of pip

by typing into command prompt the following:

python -m pip install --upgrade pip

However, I am STILL getting the original message when trying to install Oracle VM VirtualBox 7.0.6.

Missing Dependencies Python Core / win32 api

:cry:

Hi @Lisa ,
Where are you trying to install?

Did you try to install the older version of the VirtualBox?

c:\Program Files\Oracle\VirtualBox

I meant Mac or Windows? (Please share the details about the version.)