Hello Team, I have a doubt on the ETCD Backup/Restore I have taken the backup wi . . .

Venkat G:
Hello Team,
I have a doubt on the ETCD Backup/Restore
I have taken the backup with ETCD snapshot save command without any issues on the edge node.
While executing the ETCDCTL_API=3 etcdctl restore command, I got the etcdctl package is not there and suggested to install the packages
I wanted to know, Why it thrown the package not found error?
I went through the https://github.com/kodekloudhub/community-faq/blob/main/etcd-faq.md and got the little clarity. But not sure, where can I practice?
Really appreciate your help on this.
Note: I didn`t verify whether the etcd was installed as a service or as a pod or as a cluster with remote cd

@Venkat G Try this:
ETCDCTL_API=3 etcdctl snapshot restore …

Anil Kumar:
snapshot option is not available

Leo Pastor:
@Anil Kumar Try this:
ETCDCTL_API =3 etcdctl
ETCDCTL_API =3 etcdctl snapshot

You have to use that prefix, or it will take the API version 2 by default, which does not support the snapshot command. Alternatively save the API version in a variable:

export ETCDCTL_API=3

After that, your etcdctl command can be used alone and will produce the same results as

ETCDCTL_API=3 etcdctl


Anushka hasini:
@Leo Pastor But during my exam when i restore it throw etcdctl commnd is not found instead use etcdutl…so i just replace etcdctl to etcdutl in my cmd, it says etcdutl package is not there please install…Actually what is the exact scenario for this Qs, many suggesting different solution but which one we need to follow

Venkat G:
While doing the “ETCDCTL_API=3 etcdctl snapshot restore” on the edge node, if it says to use the “etcdutl” and if we didn`t find the “etcdutl” package, what should we do?
Or Did we make any mistake here?
Requesting your help on this.

Aneek Bera:
I also faced the same problem in exam

Rajya B:
Me too

Hi @Venkat G did you tried etcdctl from all the nodes of the cluster including student/base node? also you are on the right cluster while doing this?
fyr: https://github.com/etcd-io/website/issues/382
Alternatively you may submit a ticket with LF to get more details.

Anushka hasini:
@unnivkn I have followed the steps as mentioned in github, like i just replaced with etcdutl instead of etcdctl…but it throws not found error…and I am in right path during executing this task…They clearly said we have to do everything from base node

Hi @Anushka hasini please submit a ticket with LF with your experience.

Anushka hasini:
@unnivkn Yes, I done. I am awating their response.

Venkat G:
Thank you @unnivkn, I have raised the LF ticket now. Will share their response once I received.
Just, I am elaborating the scenario once again what happened

When I tried with etcdctl snapshot restore, it thrown the error like “etcdctl is deprecated and suggested to use the etcdutl”.
When I tried to use the etcdutl, it thrown package is not found.
When I tried to install through “apt-pkg etcdutl”, it thrown some other error which I didn`t remember.
My question is atlease it should not throw the “etcdutl not found” error.

In general it’s not required to install, incase you need to install, always try to use sudo before your commands to avoid any kind of permission issues.

Trung Tran:
If the etcdctl is not already there, I believed that you’re on the wrong node.

Venkat G:
Thank you @unnivkn & @Trung Tran for your responses.
I will note down.

Anushka hasini:
@Trung Tran How can we find out whether we are in correct node or not for this task. Incase, if we are in wrong node, we couldn’t find backup file right or am i wrong

i @Anushka hasini fyi:
Switch to a k8s Cluster: kubectl config use-context <user>@<cluster>
Verify your cluster: kubectl config view

Anushka hasini:
@unnivkn Thank you

Anushka hasini:
@Venkat G Did you get response from support team. I got reply and mentioned like below "our exam technical team is unable to perform an autopsy to determine if there was an issue with the environment or the issues you faced were due to "User Error"
Regardless, we would not be able to disclose specifics about what commands were executed correctly or incorrectly - as this would compromise the validity of the test.
We can suggest that you use the killer.sh simulator to get familiar with the type of tasks presented on the exam"