(Windows 10) Vagrant Up issue for Centos 7: Revocation function error

I followed the steps to create a Vagrant VM with Centos 7.
After creating the Vagrantfile in my Vagrant directory, every time I run the “vagrant up” command the attached message shows up. Please help.

Can you post the contents of your Vagrantfile?

C:\Users\Akhilesh\Vagrant>dir Vagrantfile
Volume in drive C has no label.
Volume Serial Number is 8ADD-AA75

Directory of C:\Users\Akhilesh\Vagrant

06-05-2021 22:07 3,084 Vagrantfile
1 File(s) 3,084 bytes
0 Dir(s) 482,168,913,920 bytes free

C:\Users\Akhilesh\Vagrant>type VAgrantfile
.# -- mode: ruby --
.# vi: set ft=ruby :

.# All Vagrant configuration is done below. The “2” in Vagrant.configure
.# configures the configuration version (we support older styles for
.# backwards compatibility). Please don’t change it unless you know what
.# you’re doing.
Vagrant.configure(“2”) do |config|
.# The most common configuration options are documented and commented below.
.# For a complete reference, please see the online documentation at
.# https://docs.vagrantup.com.

.# Every Vagrant development environment requires a box. You can search for
.# boxes at Discover Vagrant Boxes - Vagrant Cloud.
config.vm.box = “centos/7”

.# Disable automatic box update checking. If you disable this, then
.# boxes will only be checked for updates when the user runs
.# vagrant box outdated. This is not recommended.
.# config.vm.box_check_update = false

. # Create a forwarded port mapping which allows access to a specific port
.# within the machine from a port on the host machine. In the example below,
.# accessing “localhost:8080” will access port 80 on the guest machine.
.# NOTE: This will enable public access to the opened port
.# config.vm.network “forwarded_port”, guest: 80, host: 8080

.# Create a forwarded port mapping which allows access to a specific port
.# within the machine from a port on the host machine and only allow access
.# via to disable public access
.# config.vm.network “forwarded_port”, guest: 80, host: 8080, host_ip: “”

.# Create a private network, which allows host-only access to the machine
.# using a specific IP.
.# config.vm.network “private_network”, ip: “”

.# Create a public network, which generally matched to bridged network.
.# Bridged networks make the machine appear as another physical device on
.# your network.
.# config.vm.network “public_network”

.# Share an additional folder to the guest VM. The first argument is
.# the path on the host to the actual folder. The second argument is
.# the path on the guest to mount the folder. And the optional third
.# argument is a set of non-required options.
.# config.vm.synced_folder “…/data”, “/vagrant_data”

.# Provider-specific configuration so you can fine-tune various
.# backing providers for Vagrant. These expose provider-specific options.
.# Example for VirtualBox:
.# config.vm.provider “virtualbox” do |vb|
. # # Display the VirtualBox GUI when booting the machine
.# vb.gui = true
.# # Customize the amount of memory on the VM:
.# vb.memory = “1024”
.# end
.# View the documentation for the provider you are using for more
.# information on available options.

.# Enable provisioning with a shell script. Additional provisioners such as
.# Ansible, Chef, Docker, Puppet and Salt are also available. Please see the
.# documentation for more information about their specific syntax and use.
.# config.vm.provision “shell”, inline: <<-SHELL
.# apt-get update
.# apt-get install -y apache2

Here, I added the period in front of the comments as the text was getting Bolded automatically

Use ``` on the line before and after your file contents to format it as a code block:

my code block

That being said, can you try again with the following Vagrantfile?

Vagrant.configure("2") do |config|
  config.vm.box = "centos/7"

That’s the most basic file you can use to get a CentOS 7 box up and running. Got the config from here:

1 Like

Ok, that might not be it. The last line of your error file shows that there might be some certificate stuff going on. Are you on a corporate network?

Nope. Doing this on my personal laptop using personal network. I Searched the internet for this problem and found a thread dating back to 2018. But not sure if the issue is same.

Seems unrelated, because your box is actually hosted on vagrant cloud…
Have you tried with another image? Like Ubuntu for example. Just to know if it’s a problem with the image, or with Vagrant in general.

Hi i tried with Ubuntu and again its showing the same error.

The steps I’m following:

1.) deleting the existing Vagrantfile in my Directory.


vagrant init ubuntu/trusty64

to create the new Vagrantfile

3.) Running

vagrant up

Please let me know if I’m missing any step.

In that case, it’s not an issue with your Vagrantfile. For some reason, some TLS/SSL code is unable to verify that a certificate was signed correctly. Unfortunately, I don’t really know either how to start debugging that.

You’ll have to google some more for “The revocation function is unable to check revocation for the certificate”, because that’s your real error.

This person also seemed to have some SSL issues with Vagrant on Windows 10.

There’s a number of suggested fixes, I’d try the following first:

# Add this to your Vagrantfile

They also mention the --insecure flag, but I wouldn’t use that since it allows for man-in-the-middle attacks.

1 Like

Didn’t work. But, config.vm.box_download_insecure=true this worked. Seems unsafe as insecure flag is used. Is there any other way?

Honestly, I have no idea. I don’t know all of this certificate stuff very well, especially on Windows. But maybe your ISP is doing some nasty stuff with a HTTP proxy, I don’t know…

1 Like

Maybe…,will work with this for now.
Thanks a lot for your help. :slightly_smiling_face:

1 Like

I’m kinda curious about what’s going on though :stuck_out_tongue: But good that it’s working.

1 Like

I faced the same issue after vagrant up.(On Windows 10 OS)
Followed the StackOverflow thread mentiond above and paused my Kaspersky protection for 5 minutes. It worked. lol. Run ‘vagrant up’ after pausing.

Thanks for that thread :slight_smile: