What is the issue here?

i have changed default shell (bash) to Bourne Shell but answer is wrong , have i not changed bash properly ?

Looks like you changed the shell for the root user, not bob.

You can refer to the Hint or Solution for help.

1 Like

Yes I used 'sudo su - ’ command and executed the code , but i used password as bobs password , because it is asked “password for bob” , rather sudo su - , can we excute user specific command ‘sudo bob -’ or somethig to specific user ?

It is the password for bob to run sudo.

You have switched to root user account and executed chsh directly without any arguments, thus you have modified SHELL setting for root user and not for bob user, as changing other user’s shell would require username as the argument for chsh command. Please read carefully messages displayed by the command - it clearly tells you, that you’re “Changing the login shell for root” NOT “bob”.

1 Like

Thank you soo much , i will try and let you know

Thank you so much , i will try and let you know

I tried multiple times , but there is some thing i can not understand yet. I tried same lab several time used solution as well , still i can not figure it why the shell is not changed

The shell is changed.
The effect is not seen until the user for who the shell is changed logs in again.

After successfully running chsh, then start a new login session for bob by opening an additional terminal. You should see the effect there.

Yes after getting new terminal i can see it now. Thank you!