Terminal not accessible for Lab

Hi KodeKloud Team,

I have been trying to access the Troubleshooting lab for Kubernetes but the connection keeps on closing out. I’ve tried Google Chrome and Firefox and none of them are working for me.


Can you try using an incognito window in chrome? and please let us know if you still have the same issue

Hi Ayman,

I tried incognito mode and also attempted to start a mock exam just to see if it wasn’t the lab itself having issues and I had no luck.

Hello, @Ali-Ali
Are you on VPN?

Hi Tej-Singh-Rana,

Not on VPN. The Namespaces lab still works for me so I’m thinking it’s individual labs that are having issues at this point.


Same for me, showing “connection closed”

@Ayman @Tej-Singh-Rana It’s still not working for me.

Okay, I will take a look into this. @Ali-Ali
Can you please record it via feedback video with console log? For both the lab which one is working and which is not?
Because all the lab should work.


Hi @Tej-Singh-Rana,

None of them are working any more. I am just getting an invalid response error message now.


@Tej-Singh-Rana @Ayman

I found this post from today as well. I’ve tried a lot of different options and personally I’m not comfortable sharing a video of my desktop.


Okay, let me check with the team. @Ali-Ali
Kindly provide me some time…

Hi @Ali-Ali to help troubleshoot your issue, can you provide more details?

  1. Are you using your work laptop and accessing the labs from a corporate network? (possibly a proxy/ private network)?
    If so, can you test this from a public network (even try a mobile hotspot if possibe)

  2. What is the version of the operating system and the browser version you have been using?

  3. Can you do a quick websocket test using the link below and share the results? (do you see a “Connection ready!” message in the results?

This issue still persists…I tried everything,
1/ new browser (in fact tried 3)
2/ Normal and private browsing
3/ Tried new laptop
4/ Websocket test passed.

Please help

hello, i am having the same issue, the lab loads but the terminal keeps closing. It says connection closed
I have tried on different browsers as well (chrome and vivaldi) no luck.

help would be much appreciated!

Hi All,

The troubleshooting lab started working for me. Outside of clearing the cookies in Chrome, I also ended up deleting the cache stored on my operating system.

@Ayman @Tej-Singh-Rana

Update: After completing the first lab within troubleshooting, the next lab is again complaining about connection being closed. I repeated the same process mentioned in my previous message and that did not fix it.

Hi @vijin.palazhi ,

I have listed the answers to your questions below.

1.I am using my personal laptop.
1.1 I haven’t tested this out using another network but it was working for one of my labs in the troubleshooting section about an hour ago and then it went down again.
2. I have been using Mac OS Monterey and Chrome 99.0.4844.51
3. I do see a connection ready message showing up.

i am trying to access azure portal with credentials provided by kodekloud, but i am getting sign in failed.
PFA below.

failed

Error code: AADSTS500341

Error message: The user account 14883301-9c22-45bc-957f-6cbe1a37e542 has been deleted from the 0d7cc8e9-be54-45cc-b2e3-041a9b45aa57 directory. To sign into this application, the account must be added to the directory.

Nope same issue I tried even today not able to connect… sometimes it says connection closed sometimes it says 390cfcd93ab644e3.labs.kodekloud.com sent an invalid response.

I was able to do one lab on Thursday and one lab today. Otherwise I keep getting the same errors that are posted in this thread. I’ve also sent like 4 screen shots. And yes my wss work on the link you put in this thread and wss work for other sites.