Task Name - Linux Process Troubleshooting

I have been assigned a task, where it has been informed that apache is not working on one of the app server and asked to find it and fix it. Also asked to make sure that apache should be running on all the app servers.

I have checked and fixed the issue on one of the app server and verified that apache is running on all the 3 app servers, still my task is marked as failed, why is it so?

Its never been asked to enable the service or check any url, its just asked to start the service on all 3 app servers.

Please see below output.

[[email protected] ~]#
Active: active (running) since Fri 2020-05-15 17:33:19 UTC; 4min 13s ago
Docs: man:httpd(8)
man:apachectl(8)
Process: 386 ExecStop=/bin/kill -WINCH ${MAINPID} (code=exited, status=1/FAILURE)
Main PID: 394 (httpd)
Status: “Total requests: 0; Current requests/sec: 0; Current traffic: 0 B/sec”
CGroup: /docker/b9b3cbcc7306a280dc4e5ae0c77e61ab61ba8b3403f3448771ae6d7fb14e8cbf/system.slice/httpd.service
├─394 /usr/sbin/httpd -DFOREGROUND
├─395 /usr/sbin/httpd -DFOREGROUND
├─396 /usr/sbin/httpd -DFOREGROUND
├─397 /usr/sbin/httpd -DFOREGROUND
├─398 /usr/sbin/httpd -DFOREGROUND
└─399 /usr/sbin/httpd -DFOREGROUND

May 15 17:33:19 stapp01 systemd[1]: Starting The Apache HTTP Server…
May 15 17:33:19 stapp01 httpd[394]: AH00558: httpd: Could not reliably determine the server’s fully qualified domain name, using 172.16.238.10. …is message
May 15 17:33:19 stapp01 systemd[1]: Started The Apache HTTP Server.
Hint: Some lines were ellipsized, use -l to show in full.
[[email protected] ~]#

[[email protected] ~]#
Loaded: loaded (/usr/lib/systemd/system/httpd.service; disabled; vendor preset: disabled)
Active: active (running) since Fri 2020-05-15 17:16:03 UTC; 18min ago
Docs: man:httpd(8)
man:apachectl(8)
Main PID: 252 (httpd)
Status: “Total requests: 0; Current requests/sec: 0; Current traffic: 0 B/sec”
CGroup: /docker/fda9bcaad0f3694b7ffe26402dc334ad8d693c5e80e18416844ca463dad84b6e/system.slice/httpd.service
├─252 /usr/sbin/httpd -DFOREGROUND
├─253 /usr/sbin/httpd -DFOREGROUND
├─254 /usr/sbin/httpd -DFOREGROUND
├─255 /usr/sbin/httpd -DFOREGROUND
├─256 /usr/sbin/httpd -DFOREGROUND
└─257 /usr/sbin/httpd -DFOREGROUND

May 15 17:16:03 stapp02 systemd[1]: Starting The Apache HTTP Server…
May 15 17:16:03 stapp02 httpd[252]: AH00558: httpd: Could not reliably determine the serve…age
May 15 17:16:03 stapp02 systemd[1]: Started The Apache HTTP Server.
Hint: Some lines were ellipsized, use -l to show in full.
[[email protected] ~]#
[[email protected] ~]#

[[email protected] ~]#
Loaded: loaded (/usr/lib/systemd/system/httpd.service; disabled; vendor preset: disabled)
Active: active (running) since Fri 2020-05-15 17:16:04 UTC; 19min ago
Docs: man:httpd(8)
man:apachectl(8)
Main PID: 211 (httpd)
Status: “Total requests: 0; Current requests/sec: 0; Current traffic: 0 B/sec”
CGroup: /docker/b1b4f8f51886c120136d5b81773b242bcd5f1c5fed662128f326113c4f4d3a79/system.slice/httpd.service
├─211 /usr/sbin/httpd -DFOREGROUND
├─212 /usr/sbin/httpd -DFOREGROUND
├─213 /usr/sbin/httpd -DFOREGROUND
├─214 /usr/sbin/httpd -DFOREGROUND
├─215 /usr/sbin/httpd -DFOREGROUND
└─216 /usr/sbin/httpd -DFOREGROUND

May 15 17:16:04 stapp03 systemd[1]: Starting The Apache HTTP Server…
May 15 17:16:04 stapp03 httpd[211]: AH00558: httpd: Could not reliably determine the server’s fully qualified domain name, using 172.16.238.12. …is message
May 15 17:16:04 stapp03 systemd[1]: Started The Apache HTTP Server.
Hint: Some lines were ellipsized, use -l to show in full.
[[email protected] ~]#

@ravis85
Since question clearly states that

Identify the faulty app host and fix the issue. Make sure Apache service is up and running on all app hosts. Also do not try to change the Apache port on any host.

and you changed Apache port from 5004 to 5005 so task failed for you.

port