Task failed due to firewalld not starting

Hi, I was assigned a task to setup firewalld on all app servers. I was able to setup it in app server 1 and 2 but when I installed firewalld on app server 3, it won’t start. I tried removing firewalld and install it again but it didn’t work. Can you have look into it?

Mohammad Zahidul Alam


@zahid You could try this

systemctl restart dbus
systemctl restart firewalld
1 Like

Thanks Inderpreet. That’s very unfortunate for me that I didn’t know this and it’s costing me half of the points.


I tried Inderpreet’s suggestion but still status of firewalld is inactive dead. Also tried restarting the session about 5 times now but still no avail.

Anyone has any other suggestions?

Thanks in advance

@technosultan

run the status command with -l
sudo systemctl status firewalld -l for more details and share the output.

1 Like

HI Inderpreet, output below:

sudo systemctl status firewalld -l

● firewalld.service - firewalld - dynamic firewall daemon
Loaded: loaded (/usr/lib/systemd/system/firewalld.service; enabled; vendor preset: enabled)
Active: inactive (dead) since Wed 2021-06-16 08:10:57 UTC; 49s ago
Docs: man:firewalld(1)
Process: 232 ExecStart=/usr/sbin/firewalld --nofork --nopid $FIREWALLD_ARGS (code=exited, status=0/SUCCESS)
Main PID: 232 (code=exited, status=0/SUCCESS)

Jun 16 08:10:46 all-in-one-server.mycorp.org systemd[1]: Starting firewalld - dynamic firewall daemon…
Jun 16 08:10:47 all-in-one-server.mycorp.org systemd[1]: Started firewalld - dynamic firewall daemon.
Jun 16 08:10:49 all-in-one-server.mycorp.org firewalld[232]: WARNING: AllowZoneDrifting is enabled. This is considered an insecure configuration option. It will be removed in a future release. Please consider disabling it now.
Jun 16 08:10:50 all-in-one-server.mycorp.org firewalld[232]: WARNING: ipset not usable, disabling ipset usage in firewall.
Jun 16 08:10:53 all-in-one-server.mycorp.org firewalld[232]: WARNING: iptables not usable, disabling IPv4 firewall.
Jun 16 08:10:56 all-in-one-server.mycorp.org firewalld[232]: WARNING: ip6tables not usable, disabling IPv6 firewall.
Jun 16 08:10:57 all-in-one-server.mycorp.org firewalld[232]: WARNING: ebtables not usable, disabling ethernet bridge firewall.
Jun 16 08:10:57 all-in-one-server.mycorp.org firewalld[232]: FATAL ERROR: No IPv4 and IPv6 firewall.
Jun 16 08:10:57 all-in-one-server.mycorp.org firewalld[232]: ERROR: Raising SystemExit in run_server

Additional Info:

[email protected] /# lsmod|grep tables
ip6_tables             28672  1 ip6table_filter
ip_tables              28672  2 iptable_filter,iptable_nat
x_tables               40960  9 ip6table_filter,xt_conntrack,iptable_filter,xt_tcpudp,ipt_MASQUERADE,xt_addrtype,xt_nat,ip6_tables,ip_tables

Check this if helps

Hi,

Inderpreet, sorry for the late reply and thanks for the link. After going back to the lab one more time, the problem somehow fixed itself and I was able to complete the labs.

But nevertheless thanks again for your help

1 Like