Setup SSL for Nginx task issue

Hi Guys, need help here. I am running in to issues and not sure what steps to take, can someone guide and advise. what steps am I missing here. Any help will be appreciated

/tmp/nautilus.crt?? file permission is correct ? recheck this location because throwing error No such file.


permission seems correct
@Inderpreet can you advise if there is something I am missing here

i think file permission is 644 not 777.

@Tej-Singh-Rana you are partial right, permission is the factor also the directory as well.

Try with this:

@Tej-Singh-Rana…After installation of nginx i tried to move both cert and key to other location…but it was giving error…

You are doing from normal user. Use sudo then try mv command. If not interested to use sudo then do this to access root priviledge sudo -i

Hi @player001 @nenadmiladin @pratikshag

I am getting below error. Can you please help
certificate and key path:

same works, if i use curl with --insecure command.

Can you share error o/p? i am not seeing any error

curl -Ik https://serverip should show the index.html content right —> Welcome! but here i am getting


With help of -I flag you will get information of that particular document. Try out without using

@Tej-Singh-Rana… so you are suggesting to check with " curl -k https://serverip"

@Akash24 try this link and see if this help… Thanks it worked