Regarding the nfs server task

So I successfully finished and tested the task to install nfs server on storage server and mount a directory on all app server and it was a success. however I noticed that I didn’t need to configure the firewall… anyone knows why?

1 Like

@sherif.alaa55 Can you please provide some insights. I was trying to to install firewall which we shouldn’t do?
firewall installed.

sudo yum -y install firewalld

start the firewall and enable it to be started at boot time.

sudo systemctl start firewalld.service
sudo systemctl enable firewalld.service

Also this is the right NFS package: nfs-utils?


I thought I needed to set up the firewall like you did … but I didn’t and it worked fine. so I’m wondering how to worked without allowing from firewall

@sherif.alaa55 I think @Inderpreet can provide better insight if Firewalls are already setup in these servers & hence we needn’t to do it again. Let me try again without doing Firewall setup.

Also this is the right NFS package: nfs-utils?


yes that was the package


I don’t think it is asked in the question to setup any firewall or something. I would recommend to stick the only requirements that are mentioned in the question.


@Inderpreet that’s the challenge I was trying to highlight that there is no full proof solutions available over Internet & solution from one site to other varies. My purpose of request through the thread “Complex Tasks (600 points) should be allowed multiple times” to highlight these challenges & hence requesting to allow multiple attempts for such complex tasks & allow participants to fail & learn from it. Give them opportunity to try different approaches & evaluate the results. With current Boolean approach of either pass or fail in a single attempt is compelling many participants from trying without fear different possible options.

I hope you take corrective actions for enabling this feature ASAP.


1 Like

I was able to proceed further but at last point when I rebooted the appserver01 it didn’t come up. I was trying the following:

  1. Mount /webdata directory on all app nodes at /var/www/nfsdata directory (Create the directories if don’t exist).

sudo mkdir -p /var/www/nfsdata

ssh [email protected]
[email protected]

sudo mount -t nfs /var/www/nfsdata (For each app server)

Now we are connected with the NFS share, we will crosscheck it as follows as client machine:

df -kh or mount

The above mount command mounted the nfs shared directory on to nfs client temporarily, to mount an NFS directory permanently on your system across the reboots, we need to make an entry in “/etc/fstab“.

sudo vi /etc/fstab (For each app server) /var/www/nfsdata nfs defaults 0 0

To test if your modified /etc/fstab is working, reboot the client:


After the reboot, you should find the two NFS shares in the outputs of

df -h or mount

But after reboot I was not able to get the appserver01 back.

Please help.


@sherif.alaa55 @Inderpreet Please suggest. Purpose of rebooting of the app server was to make the mount permanent across reboots by making entry in /etc/fstab.

I didn’t need to make the mount permenant as it wasn’t mentioned in the task requirements, however in a previous task I tried to reboot the app servers and ended up couldn’t reach it and failed the task … so I learned not to do that anymore

1 Like

@sherif.alaa55 Thanks for your response let me try this.

@Inderpreet & KodeKloud team this is challenge I am trying to highlight Internet based solutions varies from site to site & which one will click can’t be guaranteed or confirmed in a single iteration or try.

Like in this case first we struggled due to firewall enabling or not enabling now rebooting or not rebooting but looking at solution on Internet you will be forced to accept that it’s better to take these steps (firewall enable or reboot app server).

I hope you agree with my concerns.



We suggest you all to stick to the instructions/requirements that are mentioned in the questions. We agree there are variety of solutions available on internet and there might be different results accordingly. But its up to you to understand the requirements and identify the valid solution for it. That’s where learning starts :slight_smile:

Further we are working on to give multiple tries for at least complex tasks, as soon as we implement something like that we will announce.


Thank you @sherif.alaa55 for all help. Finally I was able to finish this task successfully. It was challenging & had to refine solutions multiple times.

@Inderpreet & KodeKloud team when I submitted the task got an error message saying the connection lost or environment expired but after refresh of the session got the points.


hello all friends
i have a problem when using
sudo mount -t nfs /var/www/html
after waiting for some time i got error "mount.nfs: connection refused "
can anyone please tell what is the problem
the file /etc/fstab is also not present in servers kindly reply if anyone know the problem

thanks in advance

Good to hear @pmpcert2013 :slight_smile:

@ghori83 already reverted to another thread you created.