Puppet Symlink Task

Hi all,

I don’t know if it is just me but every time I try to complete a puppet task my environment seems to have a bad configuration.

  1. The puppet path is not set in $PATH
  2. Puppet certificates are not matching
    — After renewing certificates, my puppet file “blog.pp” is not working due to a permissions problem and I can’t figured out why
  • I renewed master certificate using #puppetserver ca clean --certname stapp01.stratos…
  • I renewed agent certificate removing ssl directory

@Inderpreet @Ayman @kodekloud-support3 Could you help me clarify if there is something I’m doing wrong?

@andrzej @Goldenor @kleansoul @bladimirh @salilpune1 Guys, I know you had some issues with puppet tasks, did you experience something like this in your tasks environments? Could you help me identify if I am doing something wrong?

Thanks in advance

I guess that u should connect as root, cause you have permission denied errors

I agree with @Goldenor, the issue seems to be of permissions. Rest you do not need to delete the certificate and renew them. Maybe the other error is because you tried to delete and renew the certificate.

Where do I need to connect as root?
In puppet code *.pp?
If so, how to specify to connect as root in puppet code?

Yes, I know there is a permissions issue. I don’t know where should I specify to connect as root.

Did you connect as root when you solved one of these puppet tasks? If so, how to?

Try from root user in app server.
Change user from root.
sudo -i
then run following command.

Thanks @Tej-Singh-Rana sudo -i solves the certs and permissions issues.
The thing about the environment $PATH without the puppet path stills there, but I can succeed with the task.
Thank you again.