Openshift local installation problem on windows 11

Hi Team,

I have followed the steps to install the Openshift local cluster but while executing the command “crc setup” getting the below error.

PS C:\Users\shaik> crc setup
INFO Using bundle path C:\Users\shaik\.crc\cache\crc_hyperv_4.13.3_amd64.crcbundle
INFO Checking minimum RAM requirements
INFO Checking if current user is in crc-users and Hyper-V admins group
INFO Checking if CRC bundle is extracted in '$HOME/.crc'
INFO Checking if C:\Users\shaik\.crc\cache\crc_hyperv_4.13.3_amd64.crcbundle exists
INFO Checking if the daemon task is installed
INFO Checking if the daemon task is running
INFO Running the daemon task
Temporary error: daemon is not running yet (x8)

After that when I run the command “crc start” getting the below error.

PS C:\Users\shaik> crc start
Is 'crc daemon' running? Cannot reach daemon API: Get "http://unix/api/version": open \\.\pipe\crc-http: The system cannot find the file specified.

Kindly help me out with this ASAP as I am stuck at the start of the course and want to complete it ASAP.


Hello Shaikhfarhanrafique,

I fixed that bug by Enabling the Hyper-V
So you need to Run the following command in your PowerShell console (As admin)

Enable-WindowsOptionalFeature -Online -FeatureName Microsoft-Hyper-V -All

[and than run crc start]

Best regards

Hi bensalemimenedev,

Thanks for the suggestion.

I have tried to use that command but giving the below error.

PS C:\WINDOWS\system32> Enable-WindowsOptionalFeature -Online -FeatureName Microsoft-Hyper-V -All
Enable-WindowsOptionalFeature : Feature name Microsoft-Hyper-V is unknown.
At line:1 char:1
+ Enable-WindowsOptionalFeature -Online -FeatureName Microsoft-Hyper-V  ...
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : NotSpecified: (:) [Enable-WindowsOptionalFeature], COMException
    + FullyQualifiedErrorId : Microsoft.Dism.Commands.EnableWindowsOptionalFeatureCommand

Also I have tried to use the below URL for enabling Hyper-V on windows 11 but unable to find a setting named Hyper-V in the given location.


You’re not using Windows 11 Pro right ?

Could you try this:

Best regards