LFCS Challenge1 Issues

I am facing a number of issues with LFCS challenge at the first question itself:

  1. I have added group called dba_users & user name bob is added this group,
    but after hitting check it does not verify it properly
    lfcs-issues

  2. It asks me to create a volume group called dba_storage which I have done

  3. But it asks me to create lvm volume1 from volume group called dbastorage there
    isn’t a volume group called dbastorage so the checks always fails.

  4. The next questions asks me to format the volume_1 which has not been created which I think refers to volume1 or whichever one is correct.

I think your questions have issues with names especially the ones with underscores.
Please rectify these issues.

Please check screenshots.
lfcs-issues1

Thanks & regards

Also this screenshot should verify

Hi @faisalbasha1982 ,
Thanks for sharing your feedback. I will take a look at it.
Please provide me some time.

Regards,
KodeKloud Support

bob user already exists so useradd is not the correct command. Please check for the gpasswd or usermod command.
In your case, using the -g option with useradd will change the primary group of the bob's user.
You can check the group details by using the id bob.

This issue has been fixed. Please give it another try and let me know.

Regards,

Thanks for your response, I was able to complete my tasks without issues except for
another issue which I am not able to solve. Iam not sure if this is my issue or the issue with system.

The question on mount points being persistent accross reboots is not working out for me.
Here is the command that I added to the /etc/fstab:
/dev/dba_storage/volume1 /mnt/dba_storage xfs defaults 0 2

Thanks & Regards

Hi, @faisalbasha1982!

In the screenshot you provided, you used the path /dev/dba_storage/volume_1 but the path should be /dev/mapper/dba_storage-volume_1

If you have any other issues or questions, please feel free to reach out.

Regards,
KodeKloud Support

I tried that as well and it still doesn’t work, I am not sure what I am missing?

and also this:

@faisalbasha1982, the screenshot you provided shows an incorrect path name; it is missing an underscore character between “volume” and “1.” The full string should read /dev/mapper/dba_storage-volume_1 /mnt/dba_storage xfs defaults 0 0.

Regards,
KodeKloud Support

yup this worked, thanks a lot

Hi Tej,

Facing another issue please advise, on Challenge 4,

  1. I have moved all hidden files from preserved folder to /opt/appdata/hidden
    but the check fails

  2. I have also moved all non hidden files from preserved folder to /opt/appdata/files
    but the check fails always.

I would understood if there is an issue with hidden files transfer but non hidden files transfer gives me doubts with the system or am I missing something!

Rather than posting a new thread altogether, I wanted to add that I am experiencing issues with Challenge 1 - LFCS. All tasks appear to be completed according to the topology and task lists checked, but I still receive a ‘Tasks not completed’ message.

Hi @sumutokoro ,
I checked and didn’t see any issues. You may be missing something for the “group-permissions” task.
In your case, it’s hidden, so I can’t help it.
We do have a solution for this. You can try again. Solution Link

Regards,

Hello,
I hope you are doing well

I did encounter the same issue as I was not mentioning the mappers dir in the path. But I am confused as when I did mount file system I did not use the mappers dir, then why I do have to mention this in /etc/fstab file.