Lapache tomcat not working

curl: no URL specified!
curl: try ‘curl --help’ or ‘curl --manual’ for more information

i always get this error each time i tried installing the lastest version on the apache tomcat
is there any other way to do so?, i always get stuck on this particular issue

i await your fast response

Hello, @Kings
Which URL are you using to install tomcat?

i use the sudo curl -o command yet its still not working and i dont know why its been so

do you have any other althernatives?
if yes, please i would like you to share
thanks in anticipation

Hello, @Kings
If you are having this kind of issue that means archive file is not correct. Please copy the correct URLs from the tomcat site.

[email protected] ~$ sudo tar -xvf apache-tomcat-8.5.69.tar.gz 
tar: This does not look like a tar archive

gzip: stdin: not in gzip format
tar: Child returned status 1
tar: Error is not recoverable: exiting now
[email protected] ~$ 

As I already added a note in the Solution. Tomcat version can be different at your time.
So right now, version is v8.5.72

[email protected] ~$ sudo curl -O https://downloads.apache.org/tomcat/tomcat-8/v8.5.72/bin/apache-tomcat-8.5.72.tar.gz
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100 10.0M  100 10.0M    0     0  5536k      0  0:00:01  0:00:01 --:--:-- 5533k

After that extract it and perform further tasks.