Jenkins Single Stage Pipeline

kindly help, the deployment was successful yet the task was failed. the error for the failed tasj]k also does seem right because the website was clearly running on all app servers.
@Inderpreet @rahul456 @Ayman @mmumshad

@andubodunrin Based on the approach I think the job might fail on the second run.
Have you try building the job more second, third times and verify a consistent result.

@mihsan I did the build 4 times, they were all successful.
Check the second screenshot

@andubodunrin Sorry. Yes, you are right.
I missed that.

hi @andubodunrin, as per question, you were asked to update the content of file index.html or you have not push the changes to git before clicking on finish button.

@rahul456 as shown in the first screenshot, The content of the index.html file was Welcome to Nautilus Industries!
And after the changes were effected and pushed the content is Welcome to Nautilus Group!

Same issue for me. everthing looks fine but I have an error :

- static website content is incorrect or not working on port '6000' on 'App Server 1'

However :
[[email protected] ~]$ curl -s http://localhost:6000
Welcome to Nautilus Group!

Exactly @lionel. I’ve also been given a multistage pipeline task, I don’t know how to go about it. I believe these Jenkins tasks are new rollout and we need some guidance

I’m not sure what the problem was, but this task was also failed for me too. Job ran successfully multiple times. Screenshot from 2021-02-15 14-07-40

Hi guys,

I successfully finished the task.

I had to do the following :

  • Install java on storage server (sudo yum install java-11-openjdk-devel)
  • Install several plugins (pipeline, ssh agent…)
  • Configure node agent as requested
  • Configure pipeline with the following pipeline script :
pipeline {
    agent { label 'ststor01' }
    stages {
        stage('Deploy') {
            steps {
				sh 'echo [email protected] | cp /home/sarah/web_app/* /data/'

Don’t forget to
chmod 777 /home/sarah

I thought I had to link Gitea to my Jenkins folder. (it makes more sens to me)
But it seems that you have to copy index.html directly from local directory.

Hope it will help you guys


Thank you lionel, this looks quite simple but also defeats the purpose of the task as we are just copying from folder to folder without including the scm.
I look forward to hearing from you for the MultiStage Pipeline as i have no idea how to go about the test stage

Hi guys, @rahul456 @kodekloud-support3

I ran into the same error too. Please see the screenshots. I had configured it to to pull the latest version on repo from the Gitea server, not the local repo on storage server. Not sure if the validation is checking only with the local repo on ststor01 without doing a push to origin.

Hi Lionel,

If so, it means validation is updating the files on ststor without doing a push to origin and then running the pipeline. It is not validating with the contents of Gitea repo. If some one else makes a change to Makes no sense but at least we know now what needs to be done to get this right. :slight_smile:

@andubodunrin, according to your submitted answer you havn’t made any changes in git. Or you might have made changes after submitting your answer.

hi @lionel, seems like you have already completed your task.

[email protected] .

hi @Sam @prash , sorry for the issue, this is marked pending for you, please give it an another try.

@mihsan, can you please share KKE details ?

Thanks for the response. Just to clarify, are we deploying from the recent changes( after cloning git repo) or from changes made directly in the folder directory.

@Sam, please deploy code after pushing your changes to git repository.