IP not assigned to VM


I have installed Virtual box as per instruction given and have enables network adapter settings but still IP is not assigned.


You can try the bridge interface, then hit sudo pkill dhclient and sudo dhclient to get an IP from the range of the wifi router. Just make sure that the all VMs can reach each other using ping command.

I have the same issue and upon doing so , I also come across the same issue and it is not getting resolved with the solution you provided

The proposed solution above is not working for me as well. Can anyone please help out??

Hello @aquib92taxila,
Try this sudo pkill dhclient then sudo dhclient

If the previous not working, Try the following to set a static IP with the following steps,

Within the directory /etc/sysconfig/network-scripts/ you should find the file ifcfg-INTERFACENAME (Where INTERFACENAME is the name of your interface). Open the correct file for editing with the command sudo nano /etc/sysconfig/network-scripts/ifcfg-<INTERFACENAME> or using vim editor. We need to modify that file in order to not only change the protocol from dhcp to static, but to add the specific IP address. So when you open up that file, you’ll want to change BOOTPROTO=dhcp to BOOTPROTO=static

Now you’ll need to add the entries to set not only the IP address, but the netmask, gateway, and DNS addresses. At the bottom of that file, add the following.






then restart the network service using this command systemctl restart network
Note: you need to check your PC settings first and according to these settings you will set your IP to be in the same network of your PC so you will be able to connect to the VM using putty or mobaxtrem

KodeKloud Support