Installation of Jenkins with volume is getting failed


Please check the below issue and suggest the way forward for it.

Hi @er.nir796 ,

Try running the docker command with sudo:

sudo docker run ...

KodeKloud Support


I have tried with Sudo as well but it’s getting failed.

Can you please share the link to this lab/exercise you’re doing?

KodeKloud Support

Hi Vitor,

I am doing this lab on centos-7 , and unfortunately doesn’t know how to share the link in centos lab.

Are you able to pull the images @er.nir796 ?
Can you please share the output of pulling the jenkins image?

docker pull jenkins/jenkins


I tried in the labs and didn’t see any issues.
image - jenkins/jenkins:lts-jdk11

sudo docker run -p 8080:8080 -p 50000:50000 --restart=on-failure -v jenkins_home:/var/jenkins_home jenkins/jenkins:lts-jdk11

image - jenkins/jenkins

sudo docker run -p 8080:8080 -v /root/my-jenkins-data:/var/jenkins_home -u root jenkins/jenkins

Hi Tej,

I am able to pull jenkins/jenkins but when I am trying to add volume for it. It is getting failed please check below snap and if possible please suggest further workaround-

try this command docker run -d -v jenkins_home:/var/jenkins_home -p 8080:8080 -p 50000:50000 jenkins/jenkins

Hi Ayman,

Thank you it’s running fine.