In lab 3.10, node01 didn't accept empty password

When trying to set up node exporter on nodes node01 and node02, only node02 let me log in without asking for a password.

1 Like

Hello @ethernet.zero,
I’ve tried and I could access both nodes, please reset the lab and give it a try.
ssh node01
ssh node02

1 Like

Hi @ethernet.zero,
You need to SSH from the prometheus-server instance. Nested SSH is not allowed.
This one is not allowed: -

[email protected]~ ssh node01

[email protected]~

Then try to SSH to node02 from node01: -

[email protected]~ ssh node02

It won’t work. Log out from node01 and try to SSH from the prometheus-server.

[email protected]~ ssh node02

Regards,

I know, I know, I was just trying to scp the node_exporter binary to both servers from prometheus-server:

for i in node0{1,2}; do scp node_exporter $i:~; done

Node 1 asked for password, node 2 accepted the connection right away. Then I tried just running a simple ls on them from the prometheus-server instance:

ssh node01 ls

It asked for password, while node02 just printed the output of ls.

EDIT: in the process node01 was recreated or, at least, generated a new host key. In one of my tries ssh printed the typical message about storing the new host key for the server. Maybe that helps.

I ran this command, and I had to accept the fingerprints first.

I did too. Then node01 asked for a password and node02 didn’t.

I don’t know anything about how those machines are provisioned, but when I saw that node01 changed IPs between tries it looked to me that either:

  • There’s some sort of non-consistent error when setting up authentication on those instances, or
  • There’s some sort of race condition or similar thing where you can get an instance that was provisioned for another lab.

Hi @ethernet.zero,
Did you try recently? If not, then please try once and record it. We do have a tool to record the feedback.
I will use the steps to replicate.

Regards,

I’ll try it again, thanks a lot for your help. :slightly_smiling_face:

I also can’t ssh into node01 and node2 as it’s asking for a password.

Hi @mostafahelal120,
Thanks for reporting this. Before ssh to specific node. Did you run any other steps which are not shown in the attached screenshot? That will help us to troubelshoot this.

Thanks & Regards,

For this screenshot, I only did the steps for installing Prometheus.
Also, I reset the lab and couldn’t ssh.

After some hours I reset the lab for the third time and now it’s working :slight_smile:
Thanks,