Host Only Network not showing up on Host Machine

Hello everyone, I added a Host Network and left all the defaults and applied the changes.

But the Ip Address is not showing up with ifconfig on my Ubuntu 20.04 Host…

docker0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500

enp0s25: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536

wlp3s0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500

What configuration am I missing?

Enabling / disabling DHCP does not make a difference.

Hello @proappdeveloper,
Try this sudo pkill dhclient then sudo dhclient

If the previous not working, Try the following to set a static IP with the following steps,

Within the directory /etc/sysconfig/network-scripts/ you should find the file ifcfg-INTERFACENAME (Where INTERFACENAME is the name of your interface). Open the correct file for editing with the command sudo nano /etc/sysconfig/network-scripts/ifcfg-<INTERFACENAME> or using vim editor. We need to modify that file in order to not only change the protocol from dhcp to static, but to add the specific IP address. So when you open up that file, you’ll want to change BOOTPROTO=dhcp to BOOTPROTO=static

Now you’ll need to add the entries to set not only the IP address, but the netmask, gateway, and DNS addresses. At the bottom of that file, add the following.






then restart the network service using this command systemctl restart network
Note: you need to check your PC settings first and according to these settings you will set your IP to be in the same network of your PC so you will be able to connect to the VM using putty or mobaxtrem