Hey all. So I'm stuck on a tutorial. I'm using Mac and docker and when I run `mi . . .

L M:
Hey all. So I’m stuck on a tutorial. I’m using Mac and docker and when I run minikube service hello-node the browser goes to the localhost page with a “page not found” message. When running the 192 IP address, it never loads. I’m given the following output. Anyone know a fix for this?

|-----------|------------|-------------|---------------------------|
| NAMESPACE |    NAME    | TARGET PORT |            URL            |
|-----------|------------|-------------|---------------------------|
| default   | hello-node |        8080 | <http://192.168.49.2:30257> |
|-----------|------------|-------------|---------------------------|
🏃  Starting tunnel for service hello-node.
|-----------|------------|-------------|------------------------|
| NAMESPACE |    NAME    | TARGET PORT |          URL           |
|-----------|------------|-------------|------------------------|
| default   | hello-node |             | <http://127.0.0.1:52006> |
|-----------|------------|-------------|------------------------|
🎉  Opening service default/hello-node in default browser...
❗  Because you are using a Docker driver on darwin, the terminal needs to be open to run it.

Mouhamadou Moustapha Camara:
@L M try the following command minikube service hello-node --url
On Mac and docker you need additional command
• Open a new terminal without stoping the previous process and run ps -ef | grep [email protected]
• you will have something like `

501 22391 22378   0 12:38AM ttys001    0:00.02 ssh -o UserKnownHostsFile=/dev/null -o StrictHostKeyChecking=no -N [email protected] -p 63507 -i /Users/mmkmou/.minikube/machines/minikube/id_rsa -L 64237:10.102.67.87:8080

• Open your browser and app from 127.0.0.1:64237 where 64237 is the tunnel port

1 Like

L M:
Still no luck. I get the page not found message.

L M:

ps -ef | grep [email protected]
  501 31560 31545   0  9:28AM ttys000    0:00.01 ssh -o UserKnownHostsFile=/dev/null -o StrictHostKeyChecking=no -N [email protected] -p 51845 -i /Users/lucas/.minikube/machines/minikube/id_rsa -L 52794:10.96.222.56:8080
  501 31729 31603   0  9:29AM ttys001    0:00.00 grep --color=auto --exclude-dir=.bzr --exclude-dir=CVS --exclude-dir=.git --exclude-dir=.hg --exclude-dir=.svn --exclude-dir=.idea --exclude-dir=.tox [email protected]

localhost:52794 still shows page not found.

Mouhamadou Moustapha Camara:
Hi @L M,
Please verify that all configuration is correct, if needed delete the deployment and service and create again

kubectl delete deployment hello-node
kubectl delete service hello-node


kubectl create deployment hello-minikube --image=<http://k8s.gcr.io/echoserver:1.10|k8s.gcr.io/echoserver:1.10>
`kubectl expose deployment hello-minikube --type=NodePort --port=8080`
minikube service hello-minikube --url

Than

ps -ef | grep [email protected]

Mouhamadou Moustapha Camara:



I had similar issue but this command ps -ef | grep [email protected] saved the day. Kindly take node of this number at the end of the result text 64237:10.102.67.87:8080 just after the -L flag. It will vary on your computer. Kindly use http://127.0.0.1:the-port-displayed-on-your-computer. In the case above, it will be http://127.0.0.1:64237 and i hope this helps.