Getting Vimeo screen while trying to access a lesson

When trying to access a course (doing linux basic now) , I get a Vimeo screen displayed. The video does not play and instead asks me to join Vimeo by either paying or creating a free account which is valid for 30 days. can someone please help?

1 Like

Hello @abhishek.phukan91 ,
Let me check with the team. You don’t need to create an account etc…

KodeKloud Support

@abhishek.phukan91 , One of our team members checked and didn’t find any issues with the vimeo. Could you please reset your router and test again?
If you encounter this issue again then please record a feedback video from the feedback widget tool.

KodeKloud Support

Hello, i have the same problem …
Can you help me please ?

Hello @anohshopping
Sorry for this inconvenienced caused.
A few users said that they were able to access the lecture after changing their Network. Could you please try that way?

KodeKloud Support

Hello, Thanks for your return. What do you mean by changing network ?

Like try with mobile hotspot or reset the router.

I’m having the same issue. Tried restarting my router but that did not work.

I am Having the same issue!

As I said there is no issue from our end. It’s an issue from Vimeo…
Vimeo’s support team is working on a fix. Please check the status of the Vimeo from here -

As you can see one of the services called “Embedded Player” is also down.
Let’s wait for a fix.

KodeKloud Support

Dear @benjamin.f.pratt @Anna-Fuenmayor @anohshopping @abhishek.phukan91,
Could you please try again after clearing the caches and cookies for the KK site? Seems like this issue is resolved.
Waiting for your response.

KodeKloud Support

Restarting router worked thank you