Flask Lab: Q7 gunicorn command not found error

Hi Community KodeKloud:

I am unable to run gunicorn at my lab. I have succesfully installed the gunicorn server and when I try to run the app with gunicorn app:app command i get following error:

Kindly reply me how to resolve this issue.

It seems that there is an issue with the module.

For the time being, you can install gunicorn from the source by issuing the following command.

pip install git+https://github.com/benoitc/gunicorn.git

Then run gunicorn app:app

We will fix this soon.

1 Like

@Ayman Tried but no luck

So I had to set a PATH variable for the path /usr/lib/python3.6/site-packages and was able to evoke gunicorn but that still does not seem the application is running as curl is failing. Tried to run the app just by python3 app.py then the curl was working

@Ayman would highly appreciate if it is clarified if this is an issue with the environment, python or something else?


@Ayman - Iā€™m also getting the same error.Could you please clarify to fix this issue.

Hi @Ayman team,

Unable to clear this question even after following the Hint and solutions provided here. Could you please provide a detailed explanation if possible on this question?

@praddasg , @Hariharan , @dileep.raj89 , this has been fixed. Please check and let us know if the issue persists.

I am facing below error with question 8. Please advice -

Hello @Piyushm,
It should be working as you see in the attached gif.
gunicorn app

Can you please try again?

KodeKloud Support