EX-06 Lab: Packet filtering, static routes and time synchronization-

Hello,

I’m getting the following error when configuring the suggested route: “Error: Nexthop has invalid gateway”.

I used the following command:
sudo ip route add 192.168.0.0/24 via 172.28.128.100

Please check if there is any error in the platform or my command.

Hi @irianleyva

It’s working for me. Please retry the lab and report back if still not working.

Hi, I am getting the exact same error.
Error: Nexthop has invalid gateway.
Tried today. Please have a look. Thank you.

Hi @meletiop

Still works for me. Did you do all the previous questions correctly? These change the firewall configuration and could have an effect on the outcome of Q6

Here are all the commands I ran to get from Q1 to Q6

[[email protected] ~]$ sudo firewall-cmd --add-port=7869/tcp --permanent
success
[[email protected] ~]$ sudo firewall-cmd --add-service=https --permanent
success
[[email protected] ~]$ sudo firewall-cmd --remove-port=53/udp
success
[[email protected] ~]$ sudo firewall-cmd --add-source=10.11.12.0/24 --zone=trusted --permanent
success
[[email protected] ~]$ sudo firewall-cmd --runtime-to-permanent
success
[[email protected] ~]$ sudo ip route add 192.168.0.0/24 via 172.28.128.100
[[email protected] ~]$ 

Sorry, still getting the error. I am running the same command. All previous steps were successfully completed.

Try it again from the start and if you still get the error, run the history command so I can see all the commands you entered to get there. Please paste the output of history into the chat as text, not a sceen shot.

in a code block like this please

1 sudo firewall-cmd --add-port=7869/tcp --permanent
2 sudo firewall-cmd --add-service=https --permanent
3 sudo firewall-cmd --list-all | grep udp
4 sudo firewall-cmd --remove-port=53/udp
5 sudo firewall-cmd --add-source=10.11.12.0/24 --zone=trusted --permanent
6 sudo firewall-cmd --runtime-to-permanent
7 sudo firewall-cmd --list-all --permanent
8 clear
9 sudo ip route add 192.168.0.0/24 via 172.28.128.100
10 history

1 Like

Are you doing this course direct via KodeKloud, or the Udemy one?

I have access to the labs through Udemy.

EX06

I will find out whether the Udemy version and the KodeKloud versions of the lab are exactly the same lab. They should be.

1 Like

Hi @meletiop

Seems they were different versions of the same lab. Please try it now and hopefully both issues you reported are now resolved.

Hello,
I can confirm the lab is running properly without any issues. Thank you. Has anyone else in general reported something of similar nature (different lab versions between Udemy and KK)?

Not to my knowledge, but this probably won’t be the only occasion