Errors In LAB SETUP (Virtualbox &

I am doing the DevOps Pre-Requisite course and experiencing issues in the Lab Setup section. I run on a Mac Studio with an M1 Max and installing Virtualbox in x86 presents challenges, installing it with ARM64 arch the software is in beta mode and I have issues installing CentOS 7-1908 (ARM64), it simply does not start and Virtualbox crashes. I followed the instructions provided in the video but can’t get out of this error loop. Any ideas on how to solve this?

HI, @Philippe-Xanthopoulo,

Please chck this blog about install and use virtualbox on apple M1 and M2


Hi, thank you for the post. Installing the Virtualbox beta for ARM64 is what I did. As expected it will not install in x86 arch.

The Virtualbox beta ARM64 will install and I can go through the basic setup for CentOS as in the video. That is not where i encountered problems. When I perform a normal start for CentOS then Virtualbox will crash every time I try this. Also keep in mind that the image for CentOS is from OSboxes.

Then I tried to install CentOS on Virtualbox from an iso image downloaded from the official distribution. The iso will load but at the prompt to install CentOS it does nothing. I can press enter several times and nothing happens.

I even tried to install Virtualbox x86 with Rosetta 2 and it does not work.

When Virtualbox crashes it does so at the initialization phase. CentOS is x86 based (64bit) and i suspect that it is performing system calls that the hypervisor is not able to pass correctly to the host operating system (MacOS Ventura 13.4).

From a lesson point of view I am not sure using this Virtualbox approach for M1 macs is ready for prime time. As M1/M2 macs are prevalent in the market I suggest the content producer review this approach and adjust to something that works for beginner level.

For the time being I installed Fedora 36 which is upstream from Redhat and CentOS on Parallels (license based)