Disable Root Login Task issue

I tried to complete the assigned task which is “Disable Root Login”

Steps i followed:

edited the /etc/passwd file like this


Even then also I got the status saying that the Task is failed. I believe the change that i did will disable root login.

is there anything I am missing here?
Screenshot from 2021-07-07 19-58-13

Hi @appareddy

You are disabling root login entirely but a per task you just need to disable direct SSH root login on all app.

Okay got it
Thanks for the explanation.