Disable root login-Task failed

Hi Mumshad,

I had assigned a new task based on restrict direct root access permission for all app servers. I done it through some changes in /etc/passwd file. After i changed /bin/bash to /sbin/nologin it works, I can’t able to access the app server directly by using root user. But the task was failed. What is the mistake i done here? Please help me. Also find the attached screenshot.

Muthu Kumar M.,

Hi @muthum,

I hope the task is to “Disable direct SSH root login on all app servers”. You need to modify the /etc/ssh/sshd_config file.

Hey @selan…I echo what Muthu announced. The task is just to disable root login on all App servers, which was covered by changing the shell in passwd file. Why does the task expects to edit sshd_config file ? What difference does it make ? Thanks in Advance. @mmumshad