Deploy an App on Docker Containers task - failed

Hi @Inderpreet @Ayman @kodekloud-support3,

I have the directory /var/www/html/ mapped from the host to the container php_blog yet the validation message is saying the mapping is not setup correctly. Where have I did this wrong?You can see below the index.php file is found on both html directories on the host and the container.

The html directory on stapp03

HTML directory within the container php_blog

curl test


@Inderpreet, please check this.

Thank you.

Hi @Inderpreet,

Please assist to check this. Thanks

As per the screenshot your container names also seems incorrect, are you sure the correct names were used as per the question ?


Here is my docker-compose.yml file, I have php_blog and mysql_blog container names in it. what did I miss?


I think you have to add container_name: “name” field ?

Yea, @Tej-Singh-Rana is right. For containers you need to use container_name.

ok, thanks guys @Inderpreet @Tej-Singh-Rana.

@Inderpreet @rahul456 @Ayman My task failed with the message

Can you please take a look where I did wrong? Everything worked fine when I checked.



Hi! Any update on this please?

Hi @Lakshmi, you have set ‘MYSQL_USER: root’ but root user already exists by default so during build time it will try to recreate user root and going to fail.

Thank you so much for your response. But in the task details, it’s asked for user root. That’s where I got confused. Can I retry?

@Lakshmi, did you already have today’s task in your bucket ? Please let me know once you have new task assigned for today.

As of now there is no task assigned Rahul.

@Lakshmi, this is marked pending for you, please give it an another try.

1 Like

Thank you so much! I completed the task successfully :slight_smile:

@rahul456, In this task should we specify MYSQL_USER=root or not?

@Lakshmi, I got same error msg upon submitting the task , Do we have to not set db_user=root?..I logged into app server as a root and the run the compose file by specifying db_user=root…

As per the task by default the user is root. We aren’t supposed to specify. In fact we can ignore that line.

@Lakshmi…Thanks for your response, will do the task without setting db user=root in future.