Create a Linux User with non-interactive shell guide

This is my first time working on the KodeKloud Engineer platform. I am having issues working with my first task, as I am just developing my Linux knowledge.
Task - Create a Linux User with non-interactive shell.
Can anyone help me with a guide to begin, I looked around for methods and I tried what you see in the image below.


Question is to create the user from app03 server, use ssh banner@stapp03 to get into app03 server and try. Best of Luck.

1 Like

Hello, I did that already but I don’t know the command to use. I tried the one you see in the image below, but I got an error.

1 Like

Question is to create the user from app03 server

  1. ssh [email protected]
  2. useradd username -s /sbin/nologin

Hello, I tried this, and I am still having permission denied error

Hello, bleso_a
Normal user cannot be add new user. You can add user from root user or sudo user. So try with
sudo useradd -s /sbin/nologin mark or switch into the root user sudo -i .

Hello @Tej-Singh-Rana
I am asked to provide the password for banner, which I tried to use the password for the server and it didn’t work

Can i know which password you were entering?


Password : BigGr33n

Check the keywords you were entering is not a caps.

I entered the password, just like this BigGr33n

Hmm, might be a backend issue. Try after a few min later.

Okay so this is password for banner?


Yes. To get all servers credentials. You can visit this page.

Yes, that’s where I am. I guess I will try after few mins, as you said

Thank you

To continue with the tasks on the KodeKloud Engineer platform( Nautilus).
Do you advise that I complete the DevOps prequisite course, as this is my first time with DevOps.

Yes, you can. At the beginning level you will get assign a role of system administrator. Linux basic and DevOps prerequisite course will help you to understand. After achieving 25k points, you will get a new role Devops Engineer in that role you will get Ansible, Docker, Puppet, Kubernetes tasks.

I am facing the same connexion issue with app01.
I used the password as mentioned in the list ‘Ir0nM@n’ but still cannot connect.

Hello, @PlayerGustavo
Please use correct username to login in app01 server. Check credentials in the below: