Access denied on mobaXterm terminal

host machine:- windows
VM:- Centos
used bridged Adapter

mobaXterm terminal:-

ssh status:-

Hello @saurabh-m,
Are you able to ping this machine from your PC?

hello @Ayman ,

when I started my VM :

  1. sshd is in an active state
  2. ping command gives the error “name or service not known”
  3. ifconfig not showing the IP address

After running nmcli con up enp0s3 :

  1. ping command running
  2. ifconfig showing the IP address

Then I start MobaXterm:

  1. MobaXterm gives error Access Denied ( I used password “”)
  2. ping command is running but 100% packet loss, 0 receixed

Hello @saurabh-m,
Can you please open the CMD on your PC and try to ping this machine?

try to change the network type of the VM to bridge.

I am facing the same issue and I do have a network set to bridged adapter already, however, am still unable to use it from MobaXterm, I have tried all the steps mentioned above. Please help as it still says Access Denied

Had the same issue.
My solution that worked:
To permit log in from MobaXTerm:
sudo vi /etc/ssh/sshd_config
PermitRootLogin yes
sudo systemctl restart sshd
The Internet connection wasn’t online, fixed it by:

Extra information:
“nmcli connection show”
If not on green, do:
“sudo nmcli device connect enp0s3”
sudo systemctl restart NetworkManager

to make it permanent:
sudo nmcli connection edit enp0s3
nmcli> set autoconnect yes
nmcli> save
nmcli> quit
sudo systemctl restart NetworkManager

Check nslookup on and ping